Analisis del Problema
Variables
lado, perimetro, area
Datos de entrada
El valor del lado
Calculos
p <- 4*lado;
area <- lado*lado;
Datos de salida
El area y el perimetro
Diseño del algoritmo
Pseudocódigo
/ejercicio No1.
Calcular el perimetro y el area del cuadrado
Proceso cuadrado
entrada y captura de datos
leer lado;
calculos
perimetro <- 4*lado;
area <- lado*lado;
salida de datos
escribir "El perimetro es= ",perimetro;
escribir "El area es= ",area;
FinProceso
Diagrama de Flufo de Datos(DFD)
cuadrado.jpg

Prueba de Escritorio
Lado
perimetro <- 4*lado
area <- lado* lado
4
16
16
5
20
25